Jump to content

Linux Compatibility Warning


Bloodknight
 Share

Recommended Posts

I'm trying to eliminate all errors and warnings from my log file, because why not right?


so anyway, I find a bunch of these warnings, now the problem is that none of the image files are being referenced directly from the script files. which confused me for a while.


then I find this little beast EditorIconRegistry::loadFromPath() which appears to be auto capitalising the first letter of every filename, I took a brief look into the source but that proved unhelpful.


It appears that this auto capitalisation comes from the platform itself and I really have no idea how to stop this short of forcing some kind of toLower() within the function and forcing people to make sure that the files are all forced lower case.

Link to comment
Share on other sites

This was partially cleared up for my by @Azaezel, in this instance seems it takes the classnames from the source, which of course has the case set in C++ and then looks for that file withe the case set.


As a weird and additional note, fixing this isnt actually as trivial as one might think...


Attempt 1 windows refused to rename the file the same name with a different case, presumably this is because of lack of case sensitivity and in its mind, me making zero changes.


attempt 2, rename all files something different in a different folder, then copy the files over the original, same problems as above


attempt 3, delete all the damn files copy over the correctly capitalised files to the folder


yay, job done.... no...


git refuses to acknowledge changing of the name to capitalised, presumably because of the OS issue of lack of case sensitivity *sigh*

Link to comment
Share on other sites

On windows if you have git bash installed you can issue git config core.ignorecase false or you can do git mv -f MyFile.name myfile.name


*Edit:

With tortoise git tools on windows you can do right click->TortoiseGit->Settings and than edit local .git/config and in the core section place ignorecase = false ...im sure other gui tools have somewhere you can change it too

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...