Jump to content

DTS Billboards - Broken?


Happenstance
 Share

Recommended Posts

I'm trying to create a dust field using a bunch of textured planes that I want to orient to face the camera. I'm exporting the mesh from Blender and adding the BB:: prefix to the name so the DAE importer automatically sets it to billboard. In game, the mesh is invisible unless I disable billboarding (or enable Z-axis billboarding which works but isn't the effect I want). If I go into wireframe mode I can see a thin line where the mesh should be, almost like the code is turning the mesh on its side and I'm looking at it from one of the edges.


I've tried everything I can think of - changing the 'up' axis on import, flipping normals, rotating the mesh before export... nothing seems to make a difference.


Anyone have any experience setting up DTS billboards?

Link to comment
Share on other sites

Apparently using a plane (even double sided) is bad voodoo for billboards. Tried with a simple cube and things are working nicely.


Edit: I see what's happening now. I rotated the plane in Blender but forgot to apply rotation before exporting so I actually was looking at it edge-on in game. The cube worked because it has depth so every angle was visible. Derp!


@Duion - And thanks, I'd forgotten about being able to change billboarding in the shape editor. Made finding the problem easier.

Edited by Happenstance
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...