Jump to content

D3D11 Shader problem on Win10, not Win7


Recommended Posts

So, do we have any kind of booby prize for longest update procrastination? :lol:

I had been off in the weeds on my own for quite some time, and then just had a half year break from all things Torque while I dealt with some unexpected personal life changes, but over the weekend I finally dusted off my Megamotion build, rolled up my sleeves, and merged in everything that has happened since January 2017. Whew!

And the good news is it seems to actually be working! On my Win7 desktop, anyway.

However, with the same codebase and all build steps faithfully reproduced on my new Win10 laptop, I ran into a shader bug.

Execution breaks in gfxD3D11Shader.cpp, line 995, with reflectionTable = NULL.

The interesting thing is on my Win7 box, this part of the code never even gets called.

I did notice we have Vulkan now (?) - my CMake setup is identical between builds, but am I supposed to be beyond D3D entirely by now, and my laptop is merely falling back to it for some reason?

Or is Vulkan something coming up in 4.0, and the problem is more that I haven't gone out and downloaded D3D11 for my laptop yet? (I assumed it was already on there.)

Anyway, as you can see I am still fairly clueless about the whole shader side of things here. Any advice would be appreciated.

Hope you all are well! Congrats on all the great work being done!

Link to comment
Share on other sites

If you see vulkan in cmake that is from sdl, no vulkan in torque yet. With the shader problem going to need a bit more information, is there anything in the log? Try running a debug build so you will get the d3d11 debug layer installed, in visual studio this will report any problems the d3d11.

Link to comment
Share on other sites

  • 2 weeks later...

Hey @Timmy, thanks for the feedback!

Turns out it was a silly n00b mistake, as usual. :roll:

I forgot to hook up "Microsoft DirectX SDK (June 2010)/Include" in my Include directories. :oops:

But now it works! Or, more accurately, now the next bug is exposed. :lol: At least we're out of shader territory again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...