Jump to content

Building on Linux

Jesse Webb

Recommended Posts

Posted (edited)

Hey, I've tried to compile the engine a few times, but I can never get it to work. I'm on Linux and use Ninja for the build. It seems to work up to the point that it's creating the executable. I always get the following message right at the end: 

collect2: error: ld returned 1 exit status
ninja: build stopped: subcommand failed.

I'm not a C/C++ programmer and am new to Cmake, so I don't know what the issue is. I followed the instructions in the docs. Any advice based on the error message?

Edited by Jesse Webb
Link to comment
Share on other sites

Posted (edited)
3 hours ago, Jason Campbell said:

I tried to compile a long time ago and got an error but I think it had to do my outdated libraries. I use Linux Mint.

When you installed the Libraries, was everything okay?


Does the Linux Binary that is available work okay?



Hey, I remember you helped me a year or two ago. I checked the installed libraries again and they were all there. Some were not completely up to date, so I went ahead and updated them. I restarted my computer and tried compiling the engine again, but I still am getting the same error.

But yeah, the Linux binary is working for me. I just wanted to try the newer Torque version since the pre-compiled binaries are over a year old. I guess I was just curious how the newer version was coming along. I don't know. Every time I get some time to learn Torque3D, it seems like I have a lot of issues that I run into. I'm sure that's just an issue with me not understanding some things, and not the engine itself. I've read through the docs some, but they feel a bit incomplete. I may end up giving Java and libGDX a try instead.

edit: Azaezel asked me to copy and paste the complete output after compilation (not just the last error message). I tried to copy it all, but my terminal wouldn't let me scroll back very far to do that.

Edited by Jesse Webb
Link to comment
Share on other sites

So I tried compiling using Make (instead of Ninja). It took about an hour to compile, compared to 20-30 minutes using Ninja. I still get errors, though.

I got this:

undefined reference to `btSimulationIslandManager::btSimulationIslandManager()

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...