Jump to content

OpenAL error on startup


Sir_Skurpsalot

Recommended Posts

Hello

Trying to check out Torque but my sound is not working. I'm using the linux binaries running linux mint. I get this error on startup:


"Failed to load OpenAL shared library. Sound will not be available

SFXALProvider - OpenAL not available."


How can I fix this? Searched and wasn't able to find anything.


Thanks for reading.

Link to comment
Share on other sites

I have openAL installed. Running openal-info shows the following:


Available playback devices:

Built-in Audio Analog Stereo

Available capture devices:

Built-in Audio Analog Stereo

Monitor of Built-in Audio Analog Stereo

Default playback device: Built-in Audio Analog Stereo

Default capture device: Built-in Audio Analog Stereo

ALC version: 1.1


** Info for device "Built-in Audio Analog Stereo" **

ALC version: 1.1

ALC extensions:

ALC_ENUMERATE_ALL_EXT, ALC_ENUMERATION_EXT, ALC_EXT_CAPTURE,

ALC_EXT_DEDICATED, ALC_EXT_disconnect, ALC_EXT_EFX,

ALC_EXT_thread_local_context, ALC_SOFTX_device_clock, ALC_SOFT_HRTF,

ALC_SOFT_loopback, ALC_SOFT_output_limiter, ALC_SOFT_pause_device

Available HRTFs:

default-44100

default-48000

OpenAL vendor string: OpenAL Community

OpenAL renderer string: OpenAL Soft

OpenAL version string: 1.1 ALSOFT 1.18.2

OpenAL extensions:

AL_EXT_ALAW, AL_EXT_BFORMAT, AL_EXT_DOUBLE, AL_EXT_EXPONENT_DISTANCE,

AL_EXT_FLOAT32, AL_EXT_IMA4, AL_EXT_LINEAR_DISTANCE, AL_EXT_MCFORMATS,

AL_EXT_MULAW, AL_EXT_MULAW_BFORMAT, AL_EXT_MULAW_MCFORMATS, AL_EXT_OFFSET,

AL_EXT_source_distance_model, AL_EXT_SOURCE_RADIUS, AL_EXT_STEREO_ANGLES,

AL_LOKI_quadriphonic, AL_SOFT_block_alignment, AL_SOFT_deferred_updates,

AL_SOFT_direct_channels, AL_SOFT_gain_clamp_ex, AL_SOFT_loop_points,

AL_SOFT_MSADPCM, AL_SOFT_source_latency, AL_SOFT_source_length,

AL_SOFT_source_resampler, AL_SOFT_source_spatialize

Available resamplers:

Nearest

Linear *

4-Point Sinc

Band-limited Sinc (12/24)

EFX version: 1.0

Max auxiliary sends: 2

Supported filters:

Low-pass, High-pass, Band-pass

Supported effects:

EAX Reverb, Reverb, Chorus, Distortion, Echo, Flanger, Ring Modulator,

Compressor, Equalizer, Dedicated Dialog, Dedicated LFE

Link to comment
Share on other sites

It is a little different on every Linux distribution and also different depending on what system you compile the binary with, for that reason I always compile with the latest Ubuntu LTS version, that way it will be compatible to most Linux users, but ideally you make an extra release for every major Linux distribution, to make sure it always works.

Link to comment
Share on other sites

Thanks for the help!

Two things:


I installed the dependencies as you suggested and now the pre-compiled version of Torque finds openAL and I can now select OpenAL as an audio provider in the options and I have sound. The annoying thing is Torque never saves any of my hardware settings though, every time I launch Torque I have to re choose my resolution and audio provider.



After I got that I tried going ahead and compiling my own Torque via the instructions in the wiki to see what would happen and that version gives the error "SFXALProvider - No valid devices found!" on startup and I do not have sound. Although one note is I did not understand step 4.3 on the wiki and just copied the folders in the Templates/Full/game to my "game" folder manually.

Link to comment
Share on other sites

Well I'll be darned. It doesn't save for me in the Options from the Main Menu either, if I don't open the World Editor and Save the Level. Never noticed that.


Try opening a level into the World Editor and go to Edit > Game Options. Make your changes.

Then go to File > Save Level.


See if that gets your changes saved.


We can get the compiling working I'm sure but first lets see if it works well.

Link to comment
Share on other sites

Well you got a more complicated error there, you may have to go through it step by step, like did the settings ever get saved before or is it just in this case? There is a function in script that will write the options into a pref file when exiting the options dialog, you could try to debug that with Torsion, but I don't know if Torsion has a Linux port yet. All I know is that it works in my game and it also works for all other people using my game, but I also have a custom function that writes the user prefs into the user home directory like it is supposed to be done and not into the game directory.

Link to comment
Share on other sites

Duion - It has always done this. I opened up scripts/gui/optionsDlg.cs and couldn't find any function in there that looked like it was supposed to save any video settings to any script, just a line for savings control bindings (which works). Maybe it isn't even supposed to save them by default?


Jason - no luck.

Link to comment
Share on other sites

This is how the function looks in my game:

https://github.com/Duion/Uebergame/blob/master/scripts/gui/optionsDlg.cs#L320-L321


I put it into the on sleep method in the options dialog, so every time the options dialog is closed the settings are saved automatically, so settings can never get lost.


The function will export any "$pref::" value which includes all settings also video settings. Second argument is the path and filename to write, where i used a custom function to get the home path, but you can directly write a file path there.


Control bindings may work for you, since they are saved in a different function to a different file, as you can see in my example as well.


A source of error may be that for certain settings you forgot to write into script to save them into pref values, it happened to me a few times. The export function only exports the pref values that have been changed, if you forgot to link the button in the options menu to change the values of course they will not be saved.

Link to comment
Share on other sites

Ok thanks, yeah I guess it just isn't scripted in by default. I'll keep playing with Torque. I tried Torque way back in 2012 and didn't really get it, then went to Unity and used that on and off up until this year, switched to Godot and have used that and made pretty good progress the past 6 months, but now I'm back to Torque giving it a second look because I really just want an FPS engine that has been proven and used in real games before where I don't have to reinvent the wheel for every little bit of basic functionality.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...