Jump to content

How to compile the engine


Recommended Posts

Is there any new tutorial how to compile the new engine version Torque3D version 4.0? I managed to compile any version so far, but now it does not work anymore. I followed this tutorial, but it does not work: http://wiki.torque3d.org/coder:compiling-in-windows


My latest error is:

Severity Code Description Project File Line Suppression State

Error C2675 unary '--': 'NetClassGroups' does not define this operator or a conversion to a type acceptable to the predefined operator (compiling source file D:\UebergameProject\Torque3D-1\Engine\source\gfx\gl\gfxGLTextureTarget.cpp) Uebergame D:\Programme\Microsoft Visual Studio 14.0\VC\include\xutility 2797


This error happens 913 times, every time inside xutility line 2797.


Do I need a new compiler, Visual Studio, Cmake Gui etc?

Link to post
Share on other sites

There were some issues with certain CMake versions and certain torque versions, new CMake not liking older torque, and the inverse at times.

Assuming you are running the preview4.0 branch then

CMake 3.17.0 works, VS 2019 and 2017 also work.


VS 2015 may well no longer support parts of C++ 11 that the engine uses, might need another dev to step in here, but those seem like very weird errors, and usually, if you get a lot then there's usually a fundamental issue of understanding between one part or another.


Quick google tells me this may be an enum related thing, which might help the versioning guys add better detail.

Link to post
Share on other sites

My Cmake is up to date ( 3.17.3 ), Visual Studio however no longer works after I upgraded to 2019, older versions are no longer available officially.


I tried to compile with LLVM and Ninja, but it fails at others issues in Cmake.


Is there any other way to compile or do I really have to bother with Visual Studio? I like how to compile on Linux, I just enter "ninja" into command line and everything just works, why can't it work like that on Windows as well?


Maybe compile on Linux but for Windows, but I never tried that.

Link to post
Share on other sites

I did that like 5 times now, I also downloaded a tool that uninstalled all my old Visual Studios, all versions and libs from 2011 to 2016 and even without anything left from Visual Studio a reinstall of 2019 still crashed. I also checked my Drive for errors, which none were found.

Link to post
Share on other sites

Yes, this is what I used and I'm on Win 7 and VS 2019 should work with it, since the support only ran out in 2020. Long Term I will probably have to compile in a Win10 virtual machine anyway, this is already what I do for Linux, since I don't want to personally use the "popular" distribution I compile on.

I will report when I tried with another machine with Win10.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...