Jump to content

OpenAL not found issue


Recommended Posts

It happened from time to time that people reported me that on Linux they had no sound because "OpenAL not found" failed to be detected.

After a distribution upgrade I had the same issue, it was very mysterious, because I had openAL installed, after trying random things I installed also the "openal-soft-devel" library and suddenly the problem was solved, the game would detect openAL and sound would work.

Now my question is: Why is that so? Someone said that when running the executable it does not list requiring OpenAL at all.

I'm using the "old" aka the current version of the engine, but I wonder if anyone had encountered similar issues and/or has fixed it already.

Link to comment
Share on other sites

Could it be related to this?

Linux : loading `libopenal.so` without having to install `libopenal-dev` · Issue #505 · TorqueGameEngines/Torque3D (github.com)


(This PR: Linux BugFix: OpenAL Loading by Ragora · Pull Request #532 · TorqueGameEngines/Torque3D (github.com))


Could you try installing libopenal-dev and see if that fixes it?

If it does, then you probably want to backport that PR in your version of the engine.


Edit: Also, as I understand the issue on GitHub, it's supposed to use the OpenAL that's bundled with Torque3D (libopenal.so.1) but it didn't. So that's why it shouldn't be a requirement per se. Also I don't think it technically "requires" OpenAL because you can run it with null devices, but you know.. You're gonna have a bad time without it.

Link to comment
Share on other sites

It is not that important I just wonder if that is fixed already, so I don't have to bother with it, normally I would just upgrade my game to the latest engine version to get the fixes, but that is not possible now, since there are no more releases.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...