Jump to content

Compiled 64 Bit EXE crashes unless using compatibility mode


Recommended Posts

Hi all,

I've been meaning to post this for a while, just never got around to it.

Using T3D 3.6.3 with AFX - Visual Studio 2010 Express - Windows SDK 7.1

When I compile to 32 bit, it's fine, game loads no problem. But our game requires the 64 bit because we re loading so much that we blow the 2 gig memory limit for 32 bit...

So, managed to compile to 64 bit a while back and it has been awesome for the game - can load as much as we want now. However, when I first went to launch it the game would crash soon after the splash screen with no error. Tried a few things and eventually found that setting the Compatibility Mode to "Windows 7" fixed the problem and the game has been running fine ever since.

But even though I found a workaround, I do not think this is ideal.

Have not read anything similar on here, so am wondering if it is my setup somehow?

What is the standard platform you all are building T3D 64 bit on? Should I use a different version of Visual Studio, or perhaps point to a different SDK? I had to install the Windows 7.1 SDK to restore my 64 bit compilers after installing Visual Studio 2010, the Express version apparently toasts them. So perhaps using the 7.1 SDK causes this somehow. Or it's the 2010 compilers maybe?

Suggestions anyone?


Link to comment
Share on other sites

  • 2 months later...

Bumping this thread, because I can't believe I am the only one who has seen this?

Is anybody out there building 64-bit executables?

No matter how I set up my Visual Studio, the resulting 64-bit exe will always crash on startup - unless I enable Windows 7 compatibility mode on it.

And this happens with all my computers in the house, it's not restricted to a specific PC.

We all run Windows 7 home premium. Also different video cards, some are Nvidia and some are Radeon. Tried on Quad-core machines with 8 gigs of ram and dual-cores with 4 gigs of ram, both need this compatibility mode on or the game will crash.

Not ideal for distribution - is nobody else having this problem?!?

Link to comment
Share on other sites

Thanks all...

That's odd then, must be our custom codebase or something. We have so many things added in that I don't know where to start looking.

Our engine code is based on the one on GitHub that had AFX merged in with 3.6.3, I think it was Azezel's or maybe someone else's can't remember. Anyhow we need AFX for various effects and we also have the MACK mixed in along with many other resources.

I guess one of these resources / add-ons is causing some incompatibility or something? Or is it maybe my development environment?

I use VC 2010 Exprpess, with all latest SDKs etc. Any more ideas? It works with compatibility mode set, but seems like it should run without needing that.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...