Jump to content

Star Trek 50th Anniversary Tribute Game


Recommended Posts

Hi all,


OK, in case any of you were NOT sick of hearing about our Star Trek project (which we've been chatting about here and at the old GG site going on 6 or 7 years now), we have some exciting news!


We are getting ready to release the latest version, just in time for the 50th Anniversary of Star Trek, and we have really tried to take things to the next level this time.


EDITED TO ADD: Beta download now available!

(UPDATED FRIDAY, APRIL 29, 2016 @ 15:00 EST - All new TOS-inspired menus!)


Download Link: http://gambitrealm.com/INSTALLER/download_release45_vr.php


Also updated screen caps below


This build is based on our custom port of Torque 3D 3.7 - the binary is now 64-bit and includes AFX, Advanced Character Kit, and Awesomium Integration Kit (among other additions). Yes, we got Awesomium working in 64-bit :)



Some of the exciting new features now in the game:


- COMPLETE WORKING TURBOLIFT SYSTEM WITH MOVING LIFTS!


- 15 training missions (Gold/Red/Blue shirts each get 5 skill tiers)

- 5 interactive episodes (watch clips and then take control of the action)

- All Decks exploration mission (entire ship accessible)

- Turbolift Shafts exploration mission (go from top to bottom of ship within the shafts)

- Deck 6 movie theater mission (watch movie trailers in the theater)


- Full Oculus Rift support (DK1 tested - don't own a DK2 so can't vouch for that)

- Full game controller support (I even got my PS3 controller to work on my PC, thinks it's an Xbox controller)

- Each mission completed unlocks a new character to play

- Unlocked characters can access specific things in the All Decks mission

- Each skill tier of missions completed unlocks an interactive episode


- We can now fly the actual Enterprise just like we fly a shuttle

- We can beam to and from planets and space stations

- Ship can warp to other locations, and you see the planets approaching


Single player only for now, but we also have a whole multiplayer angle in mind should we ever get the energy to go there... We'll see.


This will be a completely free download, meant as a tribute giveaway to Star Trek fans of all ages. We will also be including the Torque tools and some editable scripts, to allow anyone to mod this anyway they like... It's our gift to the Trek community in celebration of the 50th anniversary.


CBS/Paramount never made a game anything like this, so we did it :)


Anyhow, here are some pics to tide you over until release day... These are the mission preview images, taken from in-game screenshots.


We are aiming for a March/April release - stay tuned!


Live Long and Prosper


Cheers

Paul

(That's me in the Captain's Chair)


http://indelta.ca/ncc1701-50th/01-CaptainsChair.jpg



COMMAND OFFICER MISSIONS:


Shuttle Training

http://indelta.ca/INSTALLER/Command-01-ShuttleFlight_preview.jpg


Ensign Training

http://indelta.ca/INSTALLER/Command-02-EnsignTraining_preview.jpg


Tactical Training

http://indelta.ca/INSTALLER/Command-03-TacticalTraining_preview.jpg


Diplomacy

http://indelta.ca/INSTALLER/Command-04-Diplomacy_preview.jpg


Bridge Command Officer

http://indelta.ca/INSTALLER/Command-05-BridgeCommandOfficer_preview.jpg



OPERATIONS OFFICER MISSIONS:


Klingon Hunt

http://indelta.ca/INSTALLER/Operations-01-KlingonHunt_preview.jpg


Exterior Repair

http://indelta.ca/INSTALLER/Operations-02-ExteriorRepair_preview.jpg


Warp Engine Repair

http://indelta.ca/INSTALLER/Operations-03-WarpEngineRepair_preview.jpg


Security Detail

http://indelta.ca/INSTALLER/Operations-04-SecurityDetail_preview.jpg


Bridge Operations Officer

http://indelta.ca/INSTALLER/Operations-05-BridgeOperationsOfficer_preview.jpg



SCIENCE OFFICER MISSIONS:


Medical Training

http://indelta.ca/INSTALLER/Science-01-MedicalTraining_preview.jpg


Satellite Drop

http://indelta.ca/INSTALLER/Science-02-SatelliteDrop_preview.jpg


Probe Launch

http://indelta.ca/INSTALLER/Science-03-ProbeLaunch_preview.jpg


Science Expedition

http://indelta.ca/INSTALLER/Science-04-ScienceExpedition_preview.jpg


Bridge Science Officer

http://indelta.ca/INSTALLER/Science-05-BridgeScienceOfficer_preview.jpg



INTERACTIVE EPISODES:


http://indelta.ca/INSTALLER/Episode-01-TroubleWithTribbles_preview.jpg


http://indelta.ca/INSTALLER/Episode-02-Galileo7_preview.jpg


http://indelta.ca/INSTALLER/Episode-03-DoomsdayMachine_preview.jpg


http://indelta.ca/INSTALLER/Episode-04-Arena_preview.jpg


http://indelta.ca/INSTALLER/Episode-05-BalanceOfTerror_preview.jpg



OTHER MISSIONS:


Explore All Decks

http://indelta.ca/INSTALLER/AllDecksNew_preview.jpg


Turbolift Shafts

http://indelta.ca/INSTALLER/Deck00Turbo_preview.png


Movie Theater

http://indelta.ca/ncc1701-50th/18-TheatreScreen.jpg

Edited by PaulWeston
Link to post
Share on other sites
  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

Just unplugged after a half hour in the Rift, hunting Klingons deck to deck.


Wow, so much fun!


I wish I had a DK2, the DK1 is pretty low res and the ship doesn't look nearly as good as it should, but it's still totally immersive and a complete riot to be running around the Enterprise in virtual reality.


We had this working all before on our previous 2014 release, but that was our older ship model (we have completely rebuilt everything since) and I didn't have all these missions to play... Also we didn't have controller support so Rifting with keyboard and mouse was a bit meh.


Now I can play standing up in my living room with the Rift on and controller in-hand, so cool :)

Link to post
Share on other sites

If anyone has any ideas how to get rid of the annoying compatibility mode issue, that would be great :)


It only happens with the 64-bit .EXE. If I compile to 32-bit, it does not crash like that on load. However, the game is unplayable in 32-bit as you quickly run out of memory while exploring the ship.


So, need to figure out 64-bit issue.


Thanks

Link to post
Share on other sites

Hehe, yes I know it is silly...


I wish I knew how to solve that problem.


It's weird - it only happens in the 64-bit build, and I can actually get it to stop if I remove a bunch of my startup client and server scripts... So you'd think by using process of elimination I could easily find the one that it does not like, but for some reason it is not always the same file that crashes it.


It's like some sort of memory leak issue or corruption, it's random enough that it cannot be pinpointed easily. Debug build just dumps out in a general memory handling function so no help there.


Strange indeed.


But the compatibility mode solves it perfectly, so I just do that and call it a day for now.

Link to post
Share on other sites

Some known gameplay issues found so far, apologies for any problems:


command officer final exam: hangar turbolift is missing (to fix use F8 to engage fly mode, fly to hangar and hit f7 to spawn character at camera)


operations warp engine repair: it tells you to go to bridge to test when you should go to deck 18 engineering


operations final exam: there is no collision on port nacelle floor, you will fall through (to fix use J to engage weightless mode and you can then fly into the nacelle to repair the leaks)


science officer final exam: there may not be enough AI that spawn in medical to finish mission (to fix hit ALT-A for AI editor, go to Actions then delete and respawn group 1)


Turbolift map GUI: deck 7 has a turbolift destination just right of center that should not be there, there is no lift there anymore, I forgot to delete the option)


I'm sure there are more, feel free to post any that you find.


Cheers

Link to post
Share on other sites

I tested it now for a bit, but there is a lot of issues, I will list some:


-controls menu is broken and crashes if you try to rebind a key

-audio options crash if you try to change to xaudio

-mouse sensititivy lower by default, most people have gaming mouses with high dpi

-mouse sensitivity slider is broken, cannot be adjusted

-drop camera at player and drop player at camera should be disabled for a final game F7 and F8

-esc key does not work to exit the game

-fps counter should be off by default, this is a debug feature

-remove default ouh that hurts orc sound and it should not be played on unmount player

-the movement system with right mouse button and free look is bad, should be default shooter like, most of the time you will need default shooter perspective, only in certain situations you need freelook which ithen should be enabled with a key

-you can fall into the void on some places for example if you are on the bridge and jump down the stairs in the room behind

-space cubemap could be better, it should be rendered to the cubemap so the proportions of the stars stay correct, at the moment you can see that it is a cube, since it is just 6 sides of plain textures welded together, so the proportions of the stars are wrong

-after I died and respawned the controls where broken an the player constantly punches and kicks into the air

-you should not be able to jump out of your shuttle in space


So overall I had a lot of problems getting the game to work at all, since all the options menus are broken and I did not know what buttons to press and could not reassign them and I could not exit the game, since escape button was broken and I did not know how to respawn, so I used the F7 and F8 keys which should be disabled for the game, they are debug features, but after I did that the player constantly punched into the air, so I had to kill the whole process of the game manually and restart it all.

Link to post
Share on other sites

Yes I realized I had not updated the F1 help menu with all the controls - d'oh!


That has been done now, I posted an updated release at the same URL, same filename, it has the new help as well as fixes to the items I listed in a post just above.


If you hit F1 now, it will tell you how everything works.


The hold-right-mouse setup is because our game is AFX and uses that so you have mouse cursor control to click on things. We want it this way by default. The way you're suggesting works too, but we did not design it that way.


You can always hit V to toggle freelook and then you would get what you want.


As for the options stuff - I really never cared about that, in fact I'm going to just remove the controls menu from the options screen. People always seem to want to fuss around in there, mess things up, then complain it doesn't work lol. So, I'm going to just remove it. I will leave the Default Bind file editable for people who really need to remap their controls. I'd rather they just played the game and not worry about messing around with options :)


You are correct about falling through stairway openings and such, we have not bothered to cover up those openings in this version... Takes too long to find them all and they are different in each mission because different decks are loaded for different missions. If people stick to the mission instructions, they won't see any of that. If they go out of their way to find those places, well, then fun for them :) If you play the Explore All Decks mission, every stairway should be there and the rest of the decks should load in as you move down.


The F7 and F8, yes I will be taking them out of course - they are there now for just such situations as you required them. Same with the FPS counter. This is a Beta release for you guys to play with, I kind of left those things in there on purpose, they are not bugs lol


ESC key should work fine, like I said don't try to use the menus to remap controls, it probably messed everything up... Has that feature ever worked properly anyways in other Torque games? Seems to me it was always buggy. Better to just give people the default bind file to edit as they please I think.


I do appreciate the constructive feedback on the space cubemap - I never really gave it a serious look but you are correct in that it could be smoother. I will have our art guy take a look.


Baking light maps I have heard from a few people, but I don't think that is easy - our artist knows all about that and says for the way this is setup it is either really really difficult to do, or just is not possible. Something about how the ship model is broken up. I don't know, we'll discuss it again as it is something we do hear a lot. We would love to do anything that would make it look nicer, of course.


He really only works in Milkshape though, finds its the best tool for getting things into Torque smoothly...


So, I don't know what we can do with Milkshape models in terms of light maps, etc? Anyone have specific advice on how to go about that?


Thanks again for the feedback.

Link to post
Share on other sites

Yes, the lightmaps thing will be very difficult to realize, maybe a little easier if you have purelight, but not sure if it is worth that cost.

I would import the models into blender, add a second UV map and use lightmap unwrap, blender has already an automatic function for that, it will unwrap the model for use with lightmaps.

Then I would place lights where lights should be and then bake lightmaps, but then you would face the problem, that torque needs that lightmap in each material slot as lightmap, this system only works well if you use one atlas map for the whole model, otherwise it will be a pain.

So overall it may not be worth the effort.


I tried lightmap baking the ambient occlusion into my buildingsite map, but then found that the Torque lighting with SSAO gives a decent result.


First I would try to replace the many blank surfaces with actual textures, it may give the greatest visual improvement, you have many plain white or red surfaces, they are pretty aggressive to the eye.

Link to post
Share on other sites

FYI - I just posted a new version (same download URL, same filename, just newer RAR file)...


Includes some fixes:

- Put a Readme file in root game folder with more info

- Editable default bind file in scripts/client/afx

- Removed controls tab from Options menu

- F1 popup Help updated to include all relevant control info

- New title / splash screens

- Fixed some bugs with controls (ESC key was not always working to quit)


Thanks for the continued interest - please feel free to download the latest build and keep testing. Any feedback is good feedback.


Cheers

Link to post
Share on other sites

Yes, works better now, now the biggest issue remains the performance and a lot of clipping issues, where you can go through walls, ceilings, etc.

The polycount and drawcalls is not that bad in many places, but the performance is still extremely low, so the reason must be somewhere else.

Link to post
Share on other sites

Good to hear it is working better now...


I find Torque in general to just be a bit slow, hard to pinpoint exactly where the problem could be. Any suggestions are welcome as always :)


Maybe it's something to do with AFX - I know it does some constant raycasting for the mouse-clickable stuff, maybe that is hitting the performance. Not sure what I would do if that's the case, we really like AFX and use it for several things - the mouse clicking, various particle effects, the transporter beam, etc.


Also wondering if AFX is causing my compatibility mode issue in 64-bit. Maybe there are still a few things to do in the engine code to make it play nicely in 64-bit. I know a lot of work was done on pointers in the rest of the engine, maybe the AFX code needs some attention in that way too?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...