Jump to content

fLUnKnhaXYU

Members
  • Posts

    202
  • Joined

  • Last visited

Everything posted by fLUnKnhaXYU

  1. I found this very interesting . Any thoughts on what it means for for Torque3D / 2D ? As someone who doesnt stay on top of things in game dev I was quite surprised .
  2. What will happen in the case where you group together items in a sim set , that sets the parentGroup of the item to the name of the sim set . btw my version is 3.9
  3. Duion , 3.10 works great . My issue here is with 3.9 . This script code below , is copied from your examples linked to above , I only changed some paths and names . There are no footstep sounds by using the footstepsoundID number which in this case both materials use number 1 . I tested it with an absolutely clean 3.9 binary . /-------------------------------------------------------- singleton Material(TerrainFX_moss_gravel_dense) { mapTo = "moss_gravel_dense_base"; footstepSoundId = "1"; terrainMaterials = "1"; ShowDust = "1"; showFootprints = "1"; materialTag0 = "Terrain_Sand"; specularPower[0] = "1"; effectColor[0] = "0.803922 0.780392 0.635294 1"; effectColor[1] = "0.843137 0.780392 0.454902 0.349"; impactSoundId = "0"; }; new TerrainMaterial() { diffuseMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_mossGrvlDense/moss_gravel_dense_base.dds"; diffuseSize = "250"; detailMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_mossGrvlDense/moss_gravel_dense_detail.dds"; detailSize = "4"; detailDistance = "100"; internalName = "moss_gravel_dense"; macroSize = "20"; macroStrength = "1.2"; normalMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_mossGrvlDense/moss_gravel_dense_normal.dds"; parallaxScale = "0.05"; }; singleton Material(TerrainFX_soil_gravel) { mapTo = "soil_gravel_base"; footstepSoundId = "1"; terrainMaterials = "1"; ShowDust = "1"; showFootprints = "1"; materialTag0 = "Terrain_Sand"; specularPower[0] = "1"; effectColor[0] = "0.803922 0.780392 0.635294 1"; effectColor[1] = "0.843137 0.780392 0.454902 0.349"; impactSoundId = "0"; }; new TerrainMaterial() { diffuseMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_soilgravelbase/soil_gravel_base.dds"; diffuseSize = "250"; detailMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_soilgravelbase/soil_gravel_detail.dds"; detailDistance = "100"; macroSize = "30"; internalName = "soil_gravel"; macroStrength = "0.8"; detailSize = "4"; normalMap = "art/terrains/terrain_tiles/terrainsTiles_Konserian/TT_konserian_highlands/TT_Kons_soilgravelbase/soil_gravel_normal.dds"; parallaxScale = "0"; }; /-------------------------------------------------------- So , If you do not add anything more to the script to get the sounds by setting the footStepSoundID then I have to think that it doesnt work in 3.9 . Thank you for your attention to my issue Duion ,
  4. All Ive managed to do is use other sounds in the foot step sounds list in the material editor , other than the footstepsoundID numbers . Can someone confirm that these footstepSoundIDs work in version 3.9 . If Im remebering correctly Ive seen it work for materials to structures But , Im not having any luck with the terrain tiles .
  5. in game shows me that the SFXprofile has a datablock and when i use a playonce or play it shows an ID but , there is no sound , It does the same in 3.10 , So , no clue . The datablocks look the same in the datablock editor , re-pointing to the soft sound profile only adds .ogg extension and has no effect , as I can tell . any suggestion ?
  6. OK , found it , first I needed to check the path to the forest file in the MIS file . then I was able to use the forest editors' mesh tab to point to the new location of each item , go through all of the items one by one and all worked well . Thanks for your help .
  7. I am using an unadulterated copy of version 3.9 , the effects are working correctly except for there is no sound for the footsteps . //======================================================= // This is in the file saved by the editor at // art/materials.cs singleton Material(sand_01_FX) { mapTo = "sand";//I edited this field to point to the image name. Its the only "sand" Image being used , I think . terrainMaterials = "1";// I DO NOT KNOW WHAT THIS IS // BUT IVE SEEN IT SO I ADDED // IT TO SEE IF ITD HELP castShadows = "0"; showDust = "1"; effectColor[0] = "0.415686 0.6 0.431373 1"; effectColor[1] = "0.576471 0.156863 0.156863 1"; footstepSoundId = "0"; materialTag0 = "Miscellaneous"; }; //======================================================= // This is in the file saved by the editor at // art/terrains/materials.cs new TerrainMaterial() { diffuseMap = "art/terrains/Example/sand"; detailMap = "art/terrains/Example/sand_d"; internalName = "sand_01"; }; //======================================================= This works , with footstep sound , in version 3.10 . Thus , it becomes some sort of sound issue with 3.9 at this point , I guess . Ive tried a couple things already but , it seems there isnt anything to fix , its just not working , as if something is just undone . The dust FX is right , with the right colors , the footStepSoundID is set to 3 , the GFX profiles in the player.CS are the one being used , :?:
  8. Today , I replaced the brushes and managedItem files with the files straight from Konserian Highlands expansion . I then changed the addresses in the shapefile fields . Might be worth mentioning that I put the MIS and .FOREST and other files inside ; levels/KonserianHighlands/MIS_konserianHighLands/ , as well as , directly into the levels folder . neither way generated the forest . So , as you've said , I believe it breaks the file to change the item paths . Im pretty sure that bundling everything into the original file structure would work but my intent is to separate things a little , into specific expansion packs which sorta lends toward some organizational benefits of these nice packs various themes .
  9. lately Ive been creating the terrain tile materials for my 3.9 and 3.10 and there seems to be some difficulty with the linking of a material to a terrainMaterial in v3.9 that I dont have with 3.10 . problems that become evident with the footStepsounds and showDust features . Is anyone aware of some problem with 3.9 ? Im creating the terrainMaterials in the terrain painter editor , then a material in which I add the footstep and dust options in the material editor , then edit the material file with a mapto field .to the diffuse image . Not working for the 3.9 .I didnt see any error message concerning any sound int the log file .
  10. Ive changed the paths to the models and the forests do not generate . I was hoping itd work more like terrain materials where just the name seems to be all thats needed . I did try renaming the ItemData names found in the forest file and re-naming the brushes to match the names in the forest file neither way worked for me .Thank you Duion.
  11. Ive put what demos i could find into a single game folder and since Ive changed the folder structure a bit , the compiled forest files do not work now , Is there something/s I can do to be able to use the original forest file ?
  12. Thank you , Duion , and for all of the really nice stuff in the UberGame . Ive been enjoying rummaging through it lately .
  13. Thanks for that link Jason .
  14. Hi, Im making/going to attempt to make (using the editor) terrain tile material files using what Ive scarfed up from the demos here , including , UberGame . Id like your opinion on whether or not there is any reason for concern between using one big folder of images with one long list of materials in one .CS or using many folders with one set of images in each with one materials file in each folder . Personally , I want the many folders in the hopes of only executing what is needed for a level plus the ability to just add a new folder should the opportunity arise . But Im concerned about the effeciency when using all of the folders in the editor .
  15. You are Right Jeff . I unchecked transparency in the editor and it looked right . Thanks for your time .
  16. Hello , can anyone tell me where I can find a Gideon character model . I think it came with the Burg Demo but there isnt one included in the demo that I downloaded here .
  17. This is the models material file for that particular material . singleton Material(building_01_glassMat) { mapTo = "glassMat"; normalMap[0] = "art/shapes/building1/building_01_nm.tga"; specularMap[0] = "art/shapes/building1/building_01_spec.tga"; diffuseColor[0] = "0.152941 0.423529 0.443137 1"; specular[0] = "1 1 1 1"; specularPower[0] = "54"; doubleSided = false; translucent = "1"; translucentBlendOp = "LerpAlpha"; pixelSpecular[0] = "0"; cubemap = "GoldenHourCloudySkyCubeMap"; materialTag0 = "RoadAndPath"; glow[0] = "0"; }; This is from the .MIS new Precipitation(snowT1) { numDrops = "100000"; boxWidth = "200"; boxHeight = "100"; dropSize = "1";//------------------The size in the original picture was more like 5 splashSize = "0.5"; splashMS = "250"; animateSplashes = "1"; dropAnimateMS = "0"; fadeDist = "0"; fadeDistEnd = "0"; useTrueBillboards = "0"; useLighting = "0"; glowIntensity = "0 0 0 0"; reflect = "0"; rotateWithCamVel = "1"; doCollision = "1"; hitPlayers = "0"; hitVehicles = "0"; followCam = "1"; useWind = "0"; minSpeed = "1.5"; maxSpeed = "2"; minMass = "0.75"; maxMass = "0.85"; useTurbulence = "0"; maxTurbulence = "0.1"; turbulenceSpeed = "0.2"; dataBlock = "HeavySnow"; position = "738 -56 170"; Rotation = "1 0 0 0"; scale = "1 1 1"; canSave = "1"; canSaveDynamicFields = "1"; };
  18. hello , Rendering a material on top of the precipitation layer . the material is 1 of two from the building , glass , it uses a cube map reflection but with it using no cubemap does the same . torque3d version 3.9 Sectors Demo , model is building_01 , material is glassMat
  19. after you create your ground cover look in the inspector where it says " types ", properties for 0 - 7 , there is a field named layers . If its blank the ground cover will show everywhere , but if you you put the name of a terrain material , grass1 , snow etc.. it will only show the ground cover on that material . So what I did , was paint the area with a different material , actually , i guess , it can be the same texture with just a different name , so , the ground cover will not render there . Should work , if theres not a better way .
  20. That worked , Jeff , this is 3 armatures and 3 sub-meshes in 1 model using version 3.10 . You can see the gaps between the meshes but all animations work well . 137 bones total
  21. Oh , sm = sub mesh , Thanks a lot , Jeff . I,ll give that a try that with the v3.10 then
  22. No , I had not edited the source file . I believe that would do the trick though . Thank you , Jeff .
  23. so, this may be just redundant but heres a comparison of 3.9 (Left)and .310 (Right) . These are using the 137 bone original version of the armature , with a cam and eye added These are using the exact same folders for all of the art which are placed in each executables folder . besides the issue with the dragons rendering I am a little curious as to why the same color settings are so different in appearance . I only really noticed after i ran the sectors package in the 3.9 folder .
  24. Sorry , Jason , its been a little while since I started messing with that file and I had only used it in ver 3.9 until this .I believe Duion is correct , I use blender and exported the DAE using the baked animations file . So this is from todays further look into it . As Jason suggested I checked the nodes in the shape editor . I have a current source code so i looked and fount this tsShape.CPP line 62. U32 TSShape::smMaxSkinBones = 70 ; Some numbers from the dragon model ; number of bones in Rig = 137 number of bones in feet = 66 70 'ish so I deleted the 66 foot bones plus a few head bones and relaced the feet bones with just 4 bones . this picture shows the result . just a little messed up though . So , I guess its the bone limit then ?
×
×
  • Create New...